Bug #44

event : start randomly or punctually

Added by Anonymous over 3 years ago. Updated over 3 years ago.

Status:ClosedStart date:
Priority:ImmediateDue date:
Assignee:rdnzl% Done:

0%

Category:-
Target version:0.1.190
Resolution:fixed

Description

event seems to start randomly or punctually.
but globalvar is running. ??? (attached file)

please add other option in "edit event" (attached file)
====> LOG EVENT
or other mean for testing

Capture-200.png (94 KB) Anonymous, 11/05/2010 01:29 AM

Capture-199.png (171 KB) Anonymous, 11/05/2010 01:29 AM

8
7

History

#1 Updated by rdnzl over 3 years ago

  • Status changed from New to In Progress

event seems to start randomly or punctually.

You mean there are lines 1a and 1b in your log?

Those are not events, but checks for event triggers.
Whenever a globalvar value changes DomotiGa looks for event trigger of type GlobalVar for that variable (see end of those lines), when nothing found, nothing happens (1b.No Result).
Whenever you stop and a few moments later restart DomotiGa, variables like for example minute are changed, so immediatly after start checks for triggers happen.
If your understand the bug report wrong please tell me.

please add other option in "edit event" (attached file)

You want an option to enable debug log just for one event?
I'll look into that...
Thanks.

#2 Updated by Anonymous over 3 years ago

event seems to start randomly or punctually.

what frequency of events daemon ?
command for start/stop after change event ?

file for the "randomly" event
http://www.jfchasse.fr/events101105h1230.pdf (process 2c)

You want an option to enable debug log just for one event?
I'll look into that...

log for all events for testing ( frequency daemon, change, no change )

in th version 190, the new "Added a macro/formula editor/wizard for conditions, again thanks to Renaud Visier! " is good ==> if event works

thanks

#3 Updated by Anonymous over 3 years ago

I saw :
Description:
' EventLoop.module
' This is a program loop where all events run which are not started by a timer event.
' It will be run 4 times per second (every 250mS).

loop or daemon don't select events ?

#4 Updated by Anonymous over 3 years ago

test test test :

event test : change by "house mode" click by main/home/house mode ====> OK action tellstick rfcmd
http://www.jfchasse.fr/testeventok101105h155.png

event test : change by minute ( secondes=30 ) ==== > no action
http://www.jfchasse.fr/testeventno101105h155.png

#5 Updated by rdnzl over 3 years ago

Replying to [comment:4 JFCH]:

test test test :

event test : change by "house mode" click by main/home/house mode ====> OK action tellstick rfcmd
http://www.jfchasse.fr/testeventok101105h155.png

event test : change by minute ( secondes=30 ) ==== > no action
http://www.jfchasse.fr/testeventno101105h155.png

Seconds are not used as trigger, only minutes...
This is by design, maybe changes, but have to check the impact on cpu and db performance. So it's correct that this doesn't work.
Have to filter it out of the combobox to prevent mistakes

#6 Updated by rdnzl over 3 years ago

Replying to [comment:3 JFCH]:

I saw :
Description:
' EventLoop.module
' This is a program loop where all events run which are not started by a timer event.
' It will be run 4 times per second (every 250mS).

loop or daemon don't select events ?

The EventLoop.Run() is called 4 times per second yes.
Events there are different than the new event code, it's an old loop from misterhouse, but still needed for New_Second, New_Minute variable stuff (internally)
It will disappear in the future, the things called in that loop must be moved to predefined new events in the database.

No idea what you mean by daemon... btw.

#7 Updated by Anonymous over 3 years ago

resolved

#8 Updated by rdnzl over 3 years ago

  • Status changed from In Progress to Closed
  • Resolution set to fixed

Also available in: Atom PDF